Web Designing, Web Development, Website Design, Website Development, SEO

0091 98233 72069

COGS: CUSTOMISED, OPTIMISED, GENERALISED WEB DESIGN & WEB DEVELOPMENT SOLUTIONS

Ubuntu 10.4 install php5.2 / downgrade from php5.3 to php5.2

The following .deb files are for PHP 5.2.10, built from the Karmic (9.10) sources against the various libraries that ship with Lucid. To use them with Lucid you will need to remove all existing PHP 5.3 packages (dpkg -r <package names>) and then download and install these PHP 5.2 packages (dpkg -i <package names>). Some of these packages are optional, as a minimum you will need php5-common and libapache2-mod-php5. If you’re using Drupal you’ll likely also want php5-mysql, php5-gd, and php5-curl too.

first you need to install libdb4.7 you can install it by apt-get install lib4.7

then install php5-commong

and then other libraries

libapache2-mod-php5_5.2.10.dfsg.1-2ubuntu6.4_i386.deb
php5_5.2.10.dfsg.1-2ubuntu6.4_all.deb
php5-cgi_5.2.10.dfsg.1-2ubuntu6.4_i386.deb
php5-common_5.2.10.dfsg.1-2ubuntu6.4_i386.deb
php5-curl_5.2.10.dfsg.1-2ubuntu6.4_i386.deb
php5-gd_5.2.10.dfsg.1-2ubuntu6.4_i386.deb
php5-ldap_5.2.10.dfsg.1-2ubuntu6.4_i386.deb
php5-mhash_5.2.10.dfsg.1-2ubuntu6.4_i386.deb
php5-mysql_5.2.10.dfsg.1-2ubuntu6.4_i386.deb
php-pear_5.2.10.dfsg.1-2ubuntu6.4_all.deb

after setting up you need to change extension dir in php.ini and enable mysql extension by writing extension=mysql.so